Incorrect review scores

Incident Report for Huswell Systems Status

Update

We are actively working on resolving the issue and anticipate implementing a fix by January 13th. The delay is due to a code freeze during the Christmas holidays. Thank you for your understanding and patience.
Posted Dec 26, 2024 - 17:38 CET

Update

We have identified the issue and anticipate releasing a fix by November 8th 2024.
Posted Nov 03, 2024 - 18:17 CET

Identified

We have identified the issue and are working on a fix.
Posted Nov 03, 2024 - 14:32 CET

Investigating

We are currently investigating the issue of incorrect low review scores being displayed instead of the actual higher scores.
Posted Nov 03, 2024 - 14:25 CET
This incident affects: Website (host.huswell.com), Mobile app (Hosts), and Web app (Hosts).