Host statement & payout delays

Incident Report for Huswell Systems Status

Monitoring

The underlying technical issues affecting host statements and reconciliation have been resolved, but host payouts remain delayed for reservations with a check-out date up to and including 31/12/2025.

For current and future detailed context, communication and measures, please refer to our knowledge base:
https://support.huswell.com/host/deferred-host-payouts
Posted Jan 01, 2026 - 00:01 CET

Update

The core issue affecting host statements has been resolved. We are currently processing the outstanding backlog, which may still cause delays for payouts.
Posted Nov 18, 2025 - 08:53 CET

Investigating

We are currently investigating this issue.
Posted Sep 15, 2025 - 18:00 CEST
This incident affects: Website (host.huswell.com), Mobile app (Hosts), and Web app (Hosts).